summaryrefslogtreecommitdiff
path: root/src/systemd/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/systemd/meson.build')
-rw-r--r--src/systemd/meson.build51
1 files changed, 28 insertions, 23 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index 5f84439a58..e0c967efc5 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -5,7 +5,9 @@ _systemd_headers = '''
sd-bus-protocol.h
sd-bus-vtable.h
sd-daemon.h
+ sd-device.h
sd-event.h
+ sd-hwdb.h
sd-id128.h
sd-journal.h
sd-login.h
@@ -15,22 +17,23 @@ _systemd_headers = '''
# https://github.com/mesonbuild/meson/issues/1633
systemd_headers = files(_systemd_headers)
-# sd-device.h
-# sd-hwdb.h
-# sd-dhcp6-client.h
-# sd-dhcp6-lease.h
-# sd-dhcp-client.h
-# sd-dhcp-lease.h
-# sd-dhcp-server.h
-# sd-ipv4acd.h
-# sd-ipv4ll.h
-# sd-lldp.h
-# sd-ndisc.h
-# sd-netlink.h
-# sd-network.h
-# sd-path.h
-# sd-resolve.h
-# sd-utf8.h
+_not_installed_headers = '''
+ sd-dhcp6-client.h
+ sd-dhcp6-lease.h
+ sd-dhcp-client.h
+ sd-dhcp-lease.h
+ sd-dhcp-server.h
+ sd-ipv4acd.h
+ sd-ipv4ll.h
+ sd-lldp.h
+ sd-ndisc.h
+ sd-netlink.h
+ sd-network.h
+ sd-path.h
+ sd-radv.h
+ sd-resolve.h
+ sd-utf8.h
+'''.split()
install_headers(
systemd_headers,
@@ -62,13 +65,15 @@ if cxx.found()
endif
endif
-foreach header : _systemd_headers
+foreach header : _systemd_headers + _not_installed_headers + ['../libudev/libudev.h']
foreach opt : opts
- name = ''.join([header, ':'] + opt)
- test('cc-' + name,
- check_compilation_sh,
- args : cc.cmd_array() + ['-c', '-x'] + opt +
- ['-Werror', '-include',
- join_paths(meson.current_source_dir(), header)])
+ name = ''.join(['cc-', header.split('/')[-1], ':'] + opt)
+ if want_tests != 'false'
+ test(name,
+ check_compilation_sh,
+ args : cc.cmd_array() + ['-c', '-x'] + opt +
+ ['-Werror', '-include',
+ join_paths(meson.current_source_dir(), header)])
+ endif
endforeach
endforeach