summaryrefslogtreecommitdiff
path: root/src/systemd/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/systemd/meson.build')
-rw-r--r--src/systemd/meson.build42
1 files changed, 20 insertions, 22 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index f3b969bb2b..0f5a853e2e 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -1,15 +1,13 @@
-# -*- mode: meson -*-
-
_systemd_headers = '''
- sd-bus.h
- sd-bus-protocol.h
- sd-bus-vtable.h
- sd-daemon.h
- sd-event.h
- sd-id128.h
- sd-journal.h
- sd-login.h
- sd-messages.h
+ sd-bus.h
+ sd-bus-protocol.h
+ sd-bus-vtable.h
+ sd-daemon.h
+ sd-event.h
+ sd-id128.h
+ sd-journal.h
+ sd-login.h
+ sd-messages.h
'''.split()
# https://github.com/mesonbuild/meson/issues/1633
@@ -33,9 +31,9 @@ systemd_headers = files(_systemd_headers)
# sd-utf8.h
install_headers(
- systemd_headers,
- '_sd-common.h',
- subdir : 'systemd')
+ systemd_headers,
+ '_sd-common.h',
+ subdir : 'systemd')
############################################################
@@ -45,12 +43,12 @@ opts = [[],
['-std=iso9899:1990']]
foreach header : _systemd_headers
- foreach opt : opts
- name = ''.join([header] + opt)
- test('cc-' + name,
- check_compilation_sh,
- args : cc.cmd_array() + ['-x', 'c'] + opt +
- ['-Werror', '-include',
- join_paths(meson.current_source_dir(), header)])
- endforeach
+ foreach opt : opts
+ name = ''.join([header] + opt)
+ test('cc-' + name,
+ check_compilation_sh,
+ args : cc.cmd_array() + ['-x', 'c'] + opt +
+ ['-Werror', '-include',
+ join_paths(meson.current_source_dir(), header)])
+ endforeach
endforeach