summaryrefslogtreecommitdiff
path: root/src/systemd/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/systemd/meson.build')
-rw-r--r--src/systemd/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index e0c967efc5..75c48b07a5 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -52,8 +52,7 @@ if cc.has_argument('-std=iso9899:2017')
opts += [['c', '-std=iso9899:2017']]
endif
-cxx = find_program('c++', required : false)
-if cxx.found()
+if add_languages('cpp', required : false)
opts += [['c++'],
['c++', '-std=c++98'],
['c++', '-std=c++11']]