summaryrefslogtreecommitdiff
path: root/src/fuzz/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/fuzz/meson.build')
-rw-r--r--src/fuzz/meson.build30
1 files changed, 13 insertions, 17 deletions
diff --git a/src/fuzz/meson.build b/src/fuzz/meson.build
index 09a8c8a11d..ad44778889 100644
--- a/src/fuzz/meson.build
+++ b/src/fuzz/meson.build
@@ -1,18 +1,4 @@
# SPDX-License-Identifier: LGPL-2.1+
-# Copyright 2018 Jonathan Rudenberg
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-#
-# systemd is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public License
-# along with systemd; If not, see <http://www.gnu.org/licenses/>.
fuzzers += [
[['src/fuzz/fuzz-dns-packet.c',
@@ -22,9 +8,19 @@ fuzzers += [
[libgcrypt,
libgpg_error,
libm]],
- [['src/fuzz/fuzz-dhcp-server.c',
- ],
+
+ [['src/fuzz/fuzz-dhcp-server.c'],
[libsystemd_network,
libshared],
- []]
+ []],
+
+ [['src/fuzz/fuzz-unit-file.c'],
+ [libcore,
+ libshared],
+ [libmount]],
+
+ [['src/fuzz/fuzz-journal-remote.c'],
+ [libsystemd_journal_remote,
+ libshared],
+ []],
]