summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-04-05 16:52:44 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-04-05 22:18:31 +0200
commit8f04a1ca2bf973e5419c32adca1dcf888e0b263f (patch)
tree978baef3c11ea9c87119843b155a47618e5377ca /units/meson.build
parent3761002eeaead8392a1c1517251c4f9be7c688aa (diff)
downloadsystemd-8f04a1ca2bf973e5419c32adca1dcf888e0b263f.tar.gz
meson: also allow setting GIT_VERSION via templates
GIT_VERSION is not available as a config.h variable, because it's rendered into version.h during builds. Let's rework jinja2 rendering to also parse version.h. No functional change, the new variable is so far unused. I guess this will make partial rebuilds a bit slower, but it's useful to be able to use the full version string.
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/units/meson.build b/units/meson.build
index 8a3bd0da51..e8f81f2230 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -276,7 +276,7 @@ foreach tuple : in_units
file,
input : file + '.in',
output : file,
- command : [meson_render_jinja2, config_h, '@INPUT@', '@OUTPUT@'],
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
install : install,
install_dir : systemunitdir)