summaryrefslogtreecommitdiff
path: root/units/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2021-06-16 12:00:34 +0200
committerLennart Poettering <lennart@poettering.net>2022-03-19 00:13:55 +0100
commit4a05d7ed72be443c40d5bf9a21bc4352c0d7fbb5 (patch)
tree664e01443c541f1e745de00f8b627c7f4a867f91 /units/meson.build
parent43cc7a3ef4f6a89946e7ffd6a3112a0c1740b1ef (diff)
downloadsystemd-4a05d7ed72be443c40d5bf9a21bc4352c0d7fbb5.tar.gz
unit: add units for new "systemd-sysupdate" tool
These unit (if enabled) will try to update the OS in regular intervals. Moreover, every day in the early morning this will attempt to reboot the system if there's a newer version installed than running.
Diffstat (limited to 'units/meson.build')
-rw-r--r--units/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/units/meson.build b/units/meson.build
index 2bb0a8e845..8a3bd0da51 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -140,6 +140,8 @@ units = [
['systemd-reboot.service', ''],
['systemd-rfkill.socket', 'ENABLE_RFKILL'],
['systemd-sysext.service', 'ENABLE_SYSEXT'],
+ ['systemd-sysupdate.timer', 'ENABLE_SYSUPDATE'],
+ ['systemd-sysupdate-reboot.timer', 'ENABLE_SYSUPDATE'],
['systemd-sysusers.service', 'ENABLE_SYSUSERS',
'sysinit.target.wants/'],
['systemd-tmpfiles-clean.service', 'ENABLE_TMPFILES'],
@@ -236,6 +238,8 @@ in_units = [
['systemd-suspend.service', ''],
['systemd-sysctl.service', '',
'sysinit.target.wants/'],
+ ['systemd-sysupdate.service', 'ENABLE_SYSUPDATE'],
+ ['systemd-sysupdate-reboot.service', 'ENABLE_SYSUPDATE'],
['systemd-timedated.service', 'ENABLE_TIMEDATED',
'dbus-org.freedesktop.timedate1.service'],
['systemd-timesyncd.service', 'ENABLE_TIMESYNCD'],