summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-09-12 21:47:56 +0900
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-09-13 12:07:34 +0200
commitfd1939fbe73c59aaa911363cfa4f7be748fb1d2a (patch)
tree030c923948059e399b8eb8af2139148c4cd64597 /test/meson.build
parent964bc0ad600f6d9fb90ed82f6a302988e843336d (diff)
downloadsystemd-fd1939fbe73c59aaa911363cfa4f7be748fb1d2a.tar.gz
meson: do not build tests by default when '-Dtests=false'
[zj: it is still possible to build tests explicitly by calling ninja -C build test-name. This way we have full flexibility.]
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 8bec8dc07c..9750ff22b9 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -235,7 +235,7 @@ custom_target(
'sys',
command : [sys_script_py, meson.current_build_dir()],
output : 'sys',
- build_by_default : true)
+ build_by_default : want_tests != 'false')
if perl.found()
udev_test_pl = find_program('udev-test.pl')