summaryrefslogtreecommitdiff
path: root/src/journal/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2021-01-01 04:30:47 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-01-19 07:04:18 +0900
commit99b9f8fddd3f15ca309cc6f068fc3c33caa9fd4e (patch)
treefa9343dc3b24e95559f6c6c6a42181bc7813274a /src/journal/meson.build
parent4db4792a93e5fc6352536157cec8bdb9fccf9595 (diff)
downloadsystemd-99b9f8fddd3f15ca309cc6f068fc3c33caa9fd4e.tar.gz
sd-journal: move source files for sd-journal to src/libsystemd/sd-journal
Diffstat (limited to 'src/journal/meson.build')
-rw-r--r--src/journal/meson.build65
1 files changed, 0 insertions, 65 deletions
diff --git a/src/journal/meson.build b/src/journal/meson.build
index dd0982a158..59da7aa7e0 100644
--- a/src/journal/meson.build
+++ b/src/journal/meson.build
@@ -1,69 +1,5 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
-journal_client_sources = files('''
- audit-type.c
- audit-type.h
- catalog.c
- catalog.h
- compress.c
- compress.h
- journal-def.h
- journal-file.c
- journal-file.h
- journal-send.c
- journal-vacuum.c
- journal-vacuum.h
- journal-verify.c
- journal-verify.h
- lookup3.c
- lookup3.h
- mmap-cache.c
- mmap-cache.h
- sd-journal.c
-'''.split())
-
-if conf.get('HAVE_GCRYPT') == 1
- journal_client_sources += files('''
- journal-authenticate.c
- journal-authenticate.h
- fsprg.c
- fsprg.h
- '''.split())
-endif
-
-############################################################
-
-audit_type_includes = [config_h,
- missing_audit_h,
- 'linux/audit.h']
-if conf.get('HAVE_AUDIT') == 1
- audit_type_includes += 'libaudit.h'
-endif
-
-generate_audit_type_list = find_program('generate-audit_type-list.sh')
-audit_type_list_txt = custom_target(
- 'audit_type-list.txt',
- output : 'audit_type-list.txt',
- command : [generate_audit_type_list, cpp] + audit_type_includes,
- capture : true)
-
-audit_type_to_name = custom_target(
- 'audit_type-to-name.h',
- input : ['audit_type-to-name.awk', audit_type_list_txt],
- output : 'audit_type-to-name.h',
- command : [awk, '-f', '@INPUT0@', '@INPUT1@'],
- capture : true)
-
-journal_client_sources += [audit_type_to_name]
-
-libjournal_client = static_library(
- 'journal-client',
- journal_client_sources,
- include_directories : includes,
- c_args : ['-fvisibility=default'])
-
-############################################################
-
libjournal_core_sources = files('''
journald-audit.c
journald-audit.h
@@ -85,7 +21,6 @@ libjournal_core_sources = files('''
journald-syslog.h
journald-wall.c
journald-wall.h
- journal-internal.h
'''.split())
systemd_journald_sources = files('''