summaryrefslogtreecommitdiff
path: root/src/journal/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-06-24 14:56:28 +0200
committerLennart Poettering <lennart@poettering.net>2020-07-21 10:37:54 +0200
commit9200bb30d02f68d35c0fd820e10ff2bed06393e7 (patch)
treedfbee81edb135d9ffcabc485828861bfa18f8b71 /src/journal/meson.build
parent046c91314a4046039a344c9058d3f390d8920ab1 (diff)
downloadsystemd-9200bb30d02f68d35c0fd820e10ff2bed06393e7.tar.gz
journalctl: make pcre2 a dlopen() dependency
Let's make use of the library if it is installed, but otherwise just generate a nice error and provide all other functionality.
Diffstat (limited to 'src/journal/meson.build')
-rw-r--r--src/journal/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/journal/meson.build b/src/journal/meson.build
index 5796f77cac..3a590bdc6c 100644
--- a/src/journal/meson.build
+++ b/src/journal/meson.build
@@ -101,7 +101,11 @@ journald_gperf_c = custom_target(
systemd_cat_sources = files('cat.c')
-journalctl_sources = files('journalctl.c')
+journalctl_sources = files('''
+ journalctl.c
+ pcre2-dlopen.c
+ pcre2-dlopen.h
+'''.split())
if conf.get('HAVE_QRENCODE') == 1
journalctl_sources += files('journal-qrcode.c',