summaryrefslogtreecommitdiff
path: root/src/import/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-10-10 21:20:08 +0200
committerLennart Poettering <lennart@poettering.net>2018-11-26 18:09:01 +0100
commit1d7579c473dd665df213fbc8a30f032994546246 (patch)
tree42a05e9b2bd18f55440dd8d517ea85f2c49bd3fc /src/import/meson.build
parentb3cade0c2792298d6cce0a0b2c8c4974ed981b00 (diff)
downloadsystemd-1d7579c473dd665df213fbc8a30f032994546246.tar.gz
machine: add support for importing containers from plain directories
Fixes: #2728 This is also supposed to be preparation for doing #10234 eventually, where a very similar operation is requested: instead of importing a tree to /var/lib/machines it would need to be imported into /var/lib/portables/.
Diffstat (limited to 'src/import/meson.build')
-rw-r--r--src/import/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/import/meson.build b/src/import/meson.build
index 283ba08c67..1c15fd883f 100644
--- a/src/import/meson.build
+++ b/src/import/meson.build
@@ -38,6 +38,12 @@ systemd_import_sources = files('''
qcow2-util.h
'''.split())
+systemd_import_fs_sources = files('''
+ import-fs.c
+ import-common.c
+ import-common.h
+'''.split())
+
systemd_export_sources = files('''
export.c
export-tar.c