summaryrefslogtreecommitdiff
path: root/src/boot/efi/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-01-10 14:25:57 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-01-10 14:25:57 +0100
commit493cd5034c3eb091e7163ea1e744a4e07b410710 (patch)
tree1c4630f8a188f79c01b8ce6546f162189ee5fd14 /src/boot/efi/meson.build
parent5deb391c6e6d2b8fd7b94234efea49cd6bee0d76 (diff)
downloadsystemd-493cd5034c3eb091e7163ea1e744a4e07b410710.tar.gz
meson: use 0|1 for SD_BOOT
We converted to not using #ifdef for most of our defines because the syntax is nicer and we are protected against typos and can set -Werror=undef. Let's do the same for SD_BOOT. The define is nicely hidden in build.h for normal builds, and for EFI builds we were already setting SD_BOOT on the commandline.
Diffstat (limited to 'src/boot/efi/meson.build')
-rw-r--r--src/boot/efi/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
index 334e98c075..fb8ec26564 100644
--- a/src/boot/efi/meson.build
+++ b/src/boot/efi/meson.build
@@ -175,7 +175,7 @@ efi_config_h = configure_file(
efi_cflags = [
'-DGNU_EFI_USE_MS_ABI',
- '-DSD_BOOT',
+ '-DSD_BOOT=1',
'-ffreestanding',
'-fshort-wchar',
'-fvisibility=hidden',