summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2019-05-21 08:35:10 +0900
committerGitHub <noreply@github.com>2019-05-21 08:35:10 +0900
commitd7c5b3ec3e5ea446c252c07d30c32170d4d1176a (patch)
treec3d23943553af2566dd107f9821780e77a677c33 /meson.build
parent3041250a9f7426b925498bdd9616e2172bd62a0a (diff)
parentf7ebc1e29878d079f7ac1178b458229de051293b (diff)
downloadsystemd-d7c5b3ec3e5ea446c252c07d30c32170d4d1176a.tar.gz
Merge pull request #12510 from keszybz/test-directives
test: run check-directives.sh as part of the test suite
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c7c0c3ffd0..cd2fbd5796 100644
--- a/meson.build
+++ b/meson.build
@@ -2928,6 +2928,16 @@ endforeach
############################################################
+check_directives_sh = find_program('tools/check-directives.sh')
+
+if want_tests != 'false'
+ test('check-directives',
+ check_directives_sh,
+ args : project_source_root)
+endif
+
+############################################################
+
# Enable tests for all supported sanitizers
foreach tuple : sanitizers
sanitizer = tuple[0]