summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-05-07 20:46:36 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-05-20 15:44:31 +0200
commitc6448ee39eaf5cba6676239576a745cc5dabc154 (patch)
tree8f462c22ea823687a0f4ca2ff608c51ad71cc1dc /meson.build
parenta188bcffc3007178ac3367176ab996eeec9d5b29 (diff)
downloadsystemd-c6448ee39eaf5cba6676239576a745cc5dabc154.tar.gz
test: run check-directives.sh as part of the test suite
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9506274239..3bbe79f41f 100644
--- a/meson.build
+++ b/meson.build
@@ -2927,6 +2927,16 @@ endforeach
############################################################
+check_directives_sh = find_program('tools/check-directives.sh')
+
+if want_tests != 'false'
+ test('check-directives',
+ check_directives_sh,
+ args : project_source_root)
+endif
+
+############################################################
+
# Enable tests for all supported sanitizers
foreach tuple : sanitizers
sanitizer = tuple[0]