summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorƁukasz Stelmach <l.stelmach@samsung.com>2022-07-06 13:09:51 +0200
committerLuca Boccassi <luca.boccassi@gmail.com>2022-07-12 22:47:32 +0100
commitaa5ae9711ef3cd0c69b7fcfbd65bca05fb704a8a (patch)
tree093829ff70722785faef8422c0b1b88490d37875 /meson.build
parent8880c3be82cbf303b961bfdccf46b84f3fd3d37b (diff)
downloadsystemd-aa5ae9711ef3cd0c69b7fcfbd65bca05fb704a8a.tar.gz
smack: Add DefaultSmackProcessLabel to user.conf and system.conf
DefaultSmackProcessLabel tells systemd what label to assign to its child process in case SmackProcessLabel is not set in the service file. By default, when DefaultSmackProcessLabel is not set child processes inherit label from systemd. If DefaultSmackProcessLabel is set to "/" (which is an invalid character for a SMACK label) the DEFAULT_SMACK_PROCESS_LABEL set during compilation is ignored and systemd act as if the option was unset.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7db7e5ea1d..b4fd369241 100644
--- a/meson.build
+++ b/meson.build
@@ -1167,6 +1167,11 @@ if have
conf.set_quoted('SMACK_RUN_LABEL', get_option('smack-run-label'))
endif
+have = get_option('smack') and get_option('smack-default-process-label') != ''
+if have
+ conf.set_quoted('SMACK_DEFAULT_PROCESS_LABEL', get_option('smack-default-process-label'))
+endif
+
want_polkit = get_option('polkit')
install_polkit = false
install_polkit_pkla = false