summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2022-08-30 09:57:53 +0200
committerJan Janssen <medhefgo@web.de>2022-08-30 12:03:33 +0200
commita4ea5d19bb7649b6c184e7954c54ab8e68931c31 (patch)
treec8c60d3a9f816d062978b5c27099a6b35b7655c7 /meson.build
parentf996072fe05358ac24460dff1dc12dd804bf210d (diff)
downloadsystemd-a4ea5d19bb7649b6c184e7954c54ab8e68931c31.tar.gz
meson: Compile with -Werror=format-signedness
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e80634de7a..f11582131b 100644
--- a/meson.build
+++ b/meson.build
@@ -347,7 +347,6 @@ endif
# Those generate many false positives, and we do not want to change the code to
# avoid them.
basic_disabled_warnings = [
- '-Wno-format-signedness',
'-Wno-missing-field-initializers',
'-Wno-unused-parameter',
]
@@ -356,6 +355,7 @@ possible_common_cc_flags = [
'-Wdate-time',
'-Wendif-labels',
'-Werror=format=2',
+ '-Werror=format-signedness',
'-Werror=implicit-function-declaration',
'-Werror=incompatible-pointer-types',
'-Werror=int-conversion',