summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaan De Meyer <daan.j.demeyer@gmail.com>2022-06-03 13:18:10 +0200
committerYu Watanabe <watanabe.yu+github@gmail.com>2022-06-09 13:08:27 +0900
commita22f5186761a437d8845397bbbfeaf9a7d590ec2 (patch)
tree8e5ea9e7b8bbf339af621d76f57dda2e05149052 /meson.build
parentadf59bffe5fb60319fab107dd33617798894d288 (diff)
downloadsystemd-a22f5186761a437d8845397bbbfeaf9a7d590ec2.tar.gz
meson: Add nspawn-locale meson option
https://github.com/systemd/systemd/pull/23192 caused breakage in Arch Linux's build tooling. Let's give users an opt-out aside from reverting the patch. It's hardly any maintenance work on our side and gives users an easy way to revert the locale change if needed. Of course, by default we still pick C.UTF-8 if the option is not specified.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2daaf3f400..9adb2160a4 100644
--- a/meson.build
+++ b/meson.build
@@ -937,6 +937,9 @@ conf.set_quoted('NTP_SERVERS', ntp_servers)
default_locale = get_option('default-locale')
conf.set_quoted('SYSTEMD_DEFAULT_LOCALE', default_locale)
+nspawn_locale = get_option('nspawn-locale')
+conf.set_quoted('SYSTEMD_NSPAWN_LOCALE', nspawn_locale)
+
localegen_path = get_option('localegen-path')
if localegen_path != ''
conf.set_quoted('LOCALEGEN_PATH', localegen_path)