summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-11-10 11:39:15 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-11-12 09:23:31 +0100
commit827ca90986d755b008e0002f0cd80edfc7271659 (patch)
treec74ccb4c8dec4aa5d35834daad50e65828467284 /meson.build
parentcbe804947482998cc767bfb0c169e6263a6ef097 (diff)
downloadsystemd-827ca90986d755b008e0002f0cd80edfc7271659.tar.gz
meson: use warning_level=2 by default
Let's bump up the warning level, and not add by -Wextra by hand. This is the approach recommended by meson. The idea is that all projects should be as similar as possible to make it easier for users to switch between projects.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 56b7bfea70..b7017f4f40 100644
--- a/meson.build
+++ b/meson.build
@@ -8,6 +8,7 @@ project('systemd', 'c',
'prefix=/usr',
'sysconfdir=/etc',
'localstatedir=/var',
+ 'warning_level=2',
],
meson_version : '>= 0.46',
)
@@ -323,7 +324,6 @@ elif want_fuzzbuzz
endif
possible_cc_flags = [
- '-Wextra',
'-Werror=undef',
'-Wlogical-op',
'-Wmissing-include-dirs',