summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaan De Meyer <daan.j.demeyer@gmail.com>2022-06-08 22:32:49 +0200
committerLuca Boccassi <luca.boccassi@gmail.com>2022-06-09 17:44:26 +0100
commit823900222607b74c320b43ab844d4068a44c129d (patch)
treef78d364e1c7838bf4b92ea572baf46a63387f44f /meson.build
parent136f1754f97a79b8cad404c00fd4999c963bb3d7 (diff)
downloadsystemd-823900222607b74c320b43ab844d4068a44c129d.tar.gz
meson: Build with frame pointers in developer mode
Profiling tools tend to work better when binaries and libraries are compiled with frame pointers as without them there's no easy and fast way to get the current stacktrace.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9adb2160a4..4a114ed51b 100644
--- a/meson.build
+++ b/meson.build
@@ -450,6 +450,10 @@ if get_option('buildtype') != 'debug'
possible_link_flags += '-Wl,--gc-sections'
endif
+if get_option('mode') == 'developer'
+ possible_cc_flags += '-fno-omit-frame-pointer'
+endif
+
add_project_arguments(cc.get_supported_arguments(basic_disabled_warnings), language : 'c')
add_project_arguments(cc.get_supported_arguments(possible_cc_flags), language : 'c')
add_project_link_arguments(cc.get_supported_link_arguments(possible_link_flags), language : 'c')