summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-06-09 20:33:29 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-06-10 13:51:17 +0200
commit819c0dcbf510dab8044e77e98e7593b384ad908c (patch)
treed9fe3e95ce48dda2feadaeba2f748104083e55aa /meson.build
parent79dec86add2192275041f5f7452e71a206e265a0 (diff)
downloadsystemd-819c0dcbf510dab8044e77e98e7593b384ad908c.tar.gz
meson: use status-unit-format-default=name in developer mode
I think developers are particularly unlikely to find the descriptions useful, and would benefit from being able to copy&paste unit names. Let's make this choice automatically.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 630f84d702..d6391d45a2 100644
--- a/meson.build
+++ b/meson.build
@@ -226,6 +226,9 @@ endif
memory_accounting_default = get_option('memory-accounting-default')
status_unit_format_default = get_option('status-unit-format-default')
+if status_unit_format_default == 'auto'
+ status_unit_format_default = conf.get('BUILD_MODE_DEVELOPER') == 1 ? 'name' : 'description'
+endif
conf.set_quoted('BINFMT_DIR', binfmtdir)
conf.set_quoted('BOOTLIBDIR', bootlibdir)