summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-11-14 10:08:40 +0100
committerGitHub <noreply@github.com>2019-11-14 10:08:40 +0100
commit67f5b9e06eabd9bf3037caf354f77fce0117d616 (patch)
treeae751b34dd88b342d1a005481da0b003e7c7ff04 /meson.build
parente013e10d0e96917b627d54f20e3dba80a17df0d5 (diff)
parent5bc655cd20569068fde2f45ecec78c36e8ec38b0 (diff)
downloadsystemd-67f5b9e06eabd9bf3037caf354f77fce0117d616.tar.gz
Merge pull request #14003 from keszybz/user-path-configurable
meson: make user $PATH configurable
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 61c2d6aa95..c27deffa8e 100644
--- a/meson.build
+++ b/meson.build
@@ -834,6 +834,16 @@ conf.set10('ENABLE_DEBUG_SIPHASH', enable_debug_siphash)
conf.set10('VALGRIND', get_option('valgrind'))
conf.set10('LOG_TRACE', get_option('log-trace'))
+default_user_path = get_option('user-path')
+if default_user_path != ''
+ conf.set_quoted('DEFAULT_USER_PATH', default_user_path)
+ default_user_path_display = default_user_path
+else
+ # meson 0.49 fails when ?: is used in .format()
+ default_user_path_display = '(same as system services)'
+endif
+
+
#####################################################################
threads = dependency('threads')
@@ -3129,6 +3139,7 @@ status = [
'default net.naming-scheme setting: @0@'.format(default_net_naming_scheme),
'default KillUserProcesses setting: @0@'.format(kill_user_processes),
'default locale: @0@'.format(default_locale),
+ 'default user $PATH: @0@'.format(default_user_path_display),
'systemd service watchdog: @0@'.format(watchdog_opt)]
alt_dns_servers = '\n '.join(dns_servers.split(' '))