summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2022-11-11 01:17:57 +0900
committerLennart Poettering <lennart@poettering.net>2022-11-10 23:04:23 +0100
commit251dc2f14ba423f7c27dcafb6eb2c06bc94c840d (patch)
treea8919ac15e8129b6294e0609b2d67670ec802dad /meson.build
parent0b556555c2738d20693f0321d4f72ac5b3c6beed (diff)
downloadsystemd-251dc2f14ba423f7c27dcafb6eb2c06bc94c840d.tar.gz
meson: install systemd-ac-power under /usr/bin
And test the its help message. The program is useful for e.g. scripts that conditionalize their tasks to be invoked only when running on AC power.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 00daeac1b6..2d41ff8799 100644
--- a/meson.build
+++ b/meson.build
@@ -3444,15 +3444,14 @@ public_programs += executable(
install : true,
install_dir : rootlibexecdir)
-executable(
+public_programs += executable(
'systemd-ac-power',
'src/ac-power/ac-power.c',
include_directories : includes,
link_with : [libshared],
dependencies : [versiondep],
install_rpath : rootpkglibdir,
- install : true,
- install_dir : rootlibexecdir)
+ install : true)
public_programs += executable(
'systemd-detect-virt',