summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2022-07-13 02:44:50 +0200
committerGitHub <noreply@github.com>2022-07-13 02:44:50 +0200
commit0925c79c9e28c761038f04dad909b392e440fdca (patch)
tree1e09d5fed85f4ac05e0c0b7e2bfcc971f9c925a0 /meson.build
parente11d0e3925f5252a8de52dbcdcd08eab56cd0779 (diff)
parentdd2ebd1b1d5a6e5316dce252cfe3f6e7777f341c (diff)
downloadsystemd-0925c79c9e28c761038f04dad909b392e440fdca.tar.gz
Merge pull request #23881 from keszybz/kernel-install-strikes-yet-again
kernel-install: fix invocation as installkernel, add tests, tweak documentation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b4fd369241..5d7c8699fe 100644
--- a/meson.build
+++ b/meson.build
@@ -3752,7 +3752,7 @@ executable(
install : true,
install_dir : rootlibexecdir)
-public_programs += custom_target(
+exe = custom_target(
'kernel-install',
input : kernel_install_in,
output : 'kernel-install',
@@ -3760,6 +3760,13 @@ public_programs += custom_target(
install : want_kernel_install,
install_mode : 'rwxr-xr-x',
install_dir : bindir)
+public_programs += exe
+
+if want_tests != 'false'
+ test('test-kernel-install',
+ test_kernel_install_sh,
+ args : [exe.full_path(), loaderentry_install])
+endif
############################################################