summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2019-08-22 10:21:11 +0200
committerLennart Poettering <lennart@poettering.net>2019-12-09 19:25:25 +0100
commit086697094ec7ea5e51b8fb7d545ecbadab6b9a11 (patch)
treedc434a824079f73521e6f03e5960495168e68fb8 /meson.build
parentf573629c0bba7cb3cbd49f149945e802c136788a (diff)
downloadsystemd-086697094ec7ea5e51b8fb7d545ecbadab6b9a11.tar.gz
cryptsetup: add native pkcs#11 support to cryptsetup
This adds a new crypttab option for volumes "pkcs11-uri=" which takes a PKCS#11 URI. When used the key stored in the line's key file is decrypted with the private key the PKCS#11 URI indiciates. This means any smartcard that can store private RSA keys is usable for unlocking LUKS devices.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 12 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 31e7c2aa6d..004f01521c 100644
--- a/meson.build
+++ b/meson.build
@@ -2009,11 +2009,21 @@ executable('systemd-system-update-generator',
install_dir : systemgeneratordir)
if conf.get('HAVE_LIBCRYPTSETUP') == 1
+ systemd_cryptsetup_sources = files('''
+ src/cryptsetup/cryptsetup.c
+ src/cryptsetup/cryptsetup-pkcs11.h
+'''.split())
+
+ if conf.get('HAVE_P11KIT') == 1
+ systemd_cryptsetup_sources += files('src/cryptsetup/cryptsetup-pkcs11.c')
+ endif
+
executable('systemd-cryptsetup',
- 'src/cryptsetup/cryptsetup.c',
+ systemd_cryptsetup_sources,
include_directories : includes,
link_with : [libshared],
- dependencies : [libcryptsetup],
+ dependencies : [libcryptsetup,
+ libp11kit],
install_rpath : rootlibexecdir,
install : true,
install_dir : rootlibexecdir)