summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-05-16 15:43:41 +0200
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-05-19 10:24:43 +0900
commit195a8a93278632ca114c622366524f688ecc609a (patch)
treebd5b9465c00ff2e53a5eca55e4b79a4022417079 /man/meson.build
parent44ff8df77748124eb5c5f257eb585e9da26225d8 (diff)
downloadsystemd-195a8a93278632ca114c622366524f688ecc609a.tar.gz
meson: use custom configuration_data() object for man/man and man/html helpers
I want to stop using 'substs'. But in this case, configure_file() is nicer than custom_target(), because it causes meson to immediately generate the helpers after configuration, so it's possible to do 'meson build && build/man/man ...', without building anything first. We only substitute one variable here, so let's use a custom configuration_data() object.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/man/meson.build b/man/meson.build
index 2e3b858f4f..b21631b873 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -200,12 +200,15 @@ endif
############################################################
+buildroot_substs = configuration_data()
+buildroot_substs.set_quoted('BUILD_ROOT', project_build_root)
+
configure_file(
input : 'man.in',
output : 'man',
- configuration : substs)
+ configuration : buildroot_substs)
configure_file(
input : 'html.in',
output : 'html',
- configuration : substs)
+ configuration : buildroot_substs)