summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2022-08-11 22:08:10 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2022-08-11 22:08:10 +0100
commitb34092c5171b204ec5554261d66da9c8f1d64072 (patch)
tree92da978b38a9c418002910f1ef0957b0f807e86a /configure.ac
parent41fddf61ec6aa253b6a531ef33dd78fef5925e4a (diff)
downloadswig-b34092c5171b204ec5554261d66da9c8f1d64072.tar.gz
Add -pthread to lua testing
Required to fix linker errors in li_std_auto_ptr and cpp11_std_unique_ptr test cases
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 242124205..b3b1a8e48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2430,6 +2430,7 @@ if test "$LUABIN"; then
if test "$LUA_VERSION" = "5.0"; then
LUALINK="$LUALINK -llualib"
fi
+ LUALINK="$LUALINK -pthread"
LIBS=$lua_save_LIBS # restore LIBS
fi