summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2021-02-20 13:43:47 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2021-02-20 14:50:01 +0000
commitac8de714af1d7fbd755597b0f51792212f552ef7 (patch)
tree6bd67b8df6ab3aabdade91e19e1710933f03c828 /configure.ac
parentd344698934e867770a625fba3a790884812d5490 (diff)
downloadswig-ac8de714af1d7fbd755597b0f51792212f552ef7.tar.gz
Travis testing tcl for MacOSX10.14 and later
Used suggestion from https://www.postgresql-archive.org/PG-vs-macOS-Mojave-td6047357.html#a6056680 to add in sysroot. Note that the examples failed at runtime unless tcl was installed from homebrew: brew install --cask tcl
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index af4c89414..8f19c2471 100644
--- a/configure.ac
+++ b/configure.ac
@@ -496,7 +496,9 @@ fi
dirs="/usr/lib*/ /usr/lib*/tcl*/ /usr/local/lib*/ /usr/local/lib*/tcl*/"
case $host in
*-*-darwin*)
- dirs="/System/Library/Frameworks/Tcl.framework/ $dirs"
+ tcl_framework="/System/Library/Frameworks/Tcl.framework/"
+ macos_sysroot="$(xcodebuild -version -sdk macosx Path 2>/dev/null)" # For MacOSX10.14 and later
+ dirs="$macos_sysroot$tcl_framework $tcl_framework $dirs"
;;
*)
;;