summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlly Betts <olly@survex.com>2022-01-26 15:27:08 +1300
committerOlly Betts <olly@survex.com>2022-01-26 15:27:08 +1300
commit3e42fec45738d96579c65d56ef7c047fd1eaceb7 (patch)
treeebc2728d93d6f20c26b0496838980f5464af90ef /configure.ac
parentf104c4411fdb835deef91718108b47178dfab0d0 (diff)
downloadswig-3e42fec45738d96579c65d56ef7c047fd1eaceb7.tar.gz
Use CFLAGS for testcases on AIX
On AIX, one can compile applications either in 32bit or 64bit. With GCC, this is done by using: -maix64 or -maix32 (default). Thus, when building & testing Swig in 64bit, the -maix64 option must be passed to all calls to gcc. Fixes #1923
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3353487a1..5a9cea5ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,6 +289,7 @@ case $host in
else PLATCFLAGS=
# else PLATCFLAGS="-errtags=yes" # Need more work as C examples use ld for linking
fi;;
+ *-*-aix*) PLATCFLAGS="$CFLAGS";;
*) PLATCFLAGS=
esac
AC_MSG_RESULT($PLATCFLAGS)