summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichel Zou <xantares09@hotmail.com>2021-03-02 19:29:36 +0100
committerMichel Zou <xantares09@hotmail.com>2021-03-06 19:52:44 +0100
commitc6af0c5a677223868c8a515501db08defab674e9 (patch)
treefff27d8bee833e8c819c3581ffd2dcc426e221a9 /CMakeLists.txt
parent513ea736d3155989886b92e8a4bb1ee24e40a223 (diff)
downloadswig-c6af0c5a677223868c8a515501db08defab674e9.tar.gz
CMake: Escape backslashes in SWIG_LIB_WIN_UNIX
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b36f441fe..83a55d9d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,6 +78,7 @@ endif()
if (WIN32)
file (TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/${SWIG_LIB} SWIG_LIB_WIN_UNIX)
+ string (REGEX REPLACE "\\\\" "\\\\\\\\" SWIG_LIB_WIN_UNIX "${SWIG_LIB_WIN_UNIX}")
endif ()
configure_file (${SWIG_ROOT}/Tools/cmake/swigconfig.h.in
${CMAKE_CURRENT_BINARY_DIR}/Source/Include/swigconfig.h)