summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichel Zou <xantares09@hotmail.com>2021-03-06 19:57:06 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2021-03-07 11:20:39 +0000
commit167164885dfc80776178fced46a805dc768359a3 (patch)
treef5da669b88a85d4d00ca7ede26d2677141132af9 /CMakeLists.txt
parentee8d47cec4caad77d1bb8d0414416a71af332f49 (diff)
downloadswig-167164885dfc80776178fced46a805dc768359a3.tar.gz
CI: Warnings as errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83a55d9d9..0b6743471 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,10 @@ check_include_file_cxx ("boost/shared_ptr.hpp" HAVE_BOOST)
check_library_exists (dl dlopen "" HAVE_LIBDL)
check_function_exists (popen HAVE_POPEN)
+if (MSVC)
+ set (CMAKE_CXX_FLAGS "/EHsc ${CMAKE_CXX_FLAGS}")
+endif ()
+
set (PCRE_REQUIRED_ARG "REQUIRED" CACHE STRING "required arg")
find_package (PCRE ${PCRE_REQUIRED_ARG})
if (PCRE_FOUND)