summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Schueller <schueller@phimeca.com>2022-01-04 13:50:02 +0100
committerJulien Schueller <schueller@phimeca.com>2022-01-21 07:46:08 +0100
commit15515f390c5e3316a7faf0cf85d661a297d45a50 (patch)
treefd8b88f5eb76d08afb9c6fc322eb80d456ffab8a /CMakeLists.txt
parent1c76000e380992e511b16e2a9b8a6422e2947971 (diff)
downloadswig-15515f390c5e3316a7faf0cf85d661a297d45a50.tar.gz
PCRE2
Closes #2120
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a195de54..21412aa7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,11 +73,11 @@ if (MSVC)
set (CMAKE_CXX_FLAGS "/EHsc ${CMAKE_CXX_FLAGS}")
endif ()
-option (WITH_PCRE "Enable pcre" ON)
+option (WITH_PCRE "Enable PCRE" ON)
if (WITH_PCRE)
- find_package (PCRE REQUIRED)
+ find_package (PCRE2 REQUIRED)
set (HAVE_PCRE 1)
- include_directories (${PCRE_INCLUDE_DIRS})
+ include_directories (${PCRE2_INCLUDE_DIRS})
endif()
if (WIN32)
@@ -145,8 +145,8 @@ add_executable (swig
${PROJECT_BINARY_DIR}/Source/CParse/parser.c
${PROJECT_BINARY_DIR}/Source/CParse/parser.h
)
-if (PCRE_FOUND)
- target_link_libraries (swig ${PCRE_LIBRARIES})
+if (PCRE2_FOUND)
+ target_link_libraries (swig ${PCRE2_LIBRARIES})
endif ()
install (TARGETS swig DESTINATION bin)