summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorElvira Khabirova <lineprinter0@gmail.com>2020-08-20 10:31:02 +0300
committerElvira Khabirova <lineprinter0@gmail.com>2020-08-21 19:39:24 +0300
commitec595a2381bf444fb59715f2b37fd0e0df0003eb (patch)
treee250f049a3d8d4f5e0238c64ee379342faed5eaa /Makefile.am
parentc88ad3c2189af4d8dfa545a1fd78265a19447fc6 (diff)
downloadstrace-ec595a2381bf444fb59715f2b37fd0e0df0003eb.tar.gz
strace: add an option for printing syscall numbers
* print_syscall_number.c: New file. * Makefile.am (libstrace_a_SOURCES): Add it. * defs.h (struct tcb): Add true_scno field. (print_syscall_number): New function declaration. * strace.c: Add -n/--syscall-number option. (printleader): Call print_syscall_number. * syscall.c (get_scno): Assign tcp->true_scno. * tests/options-syntax.test: Check with -c/--summary-only. * strace.1.in: Document new option. * NEWS: Mention the new option.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f5447811b..4f7aceec5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -250,6 +250,7 @@ libstrace_a_SOURCES = \
print_sigevent.c \
print_statfs.c \
print_struct_stat.c \
+ print_syscall_number.c \
print_time.c \
print_timespec.h \
print_timespec32.c \