summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-04-19 01:22:29 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-04-19 01:22:29 +0000
commitacc908038e6d1cc8025d96db0eabdfcebfffd7fb (patch)
treec15ff29dcfa73946fa853424da317a1bc33fad83 /Makefile.am
parent89cce3ce53488baf6519c4f107388169fcdfc329 (diff)
downloadstrace-acc908038e6d1cc8025d96db0eabdfcebfffd7fb.tar.gz
Rework printing of SO_TIMESTAMPNS_OLD and SO_TIMESTAMPING_OLD timestamps
On architectures with 32-bit kernel_long_t the kernel sends 32-bit timespecs in SO_TIMESTAMPNS_OLD and SO_TIMESTAMPING_OLD messages. Unfortunately, this applies to all 32-bit architectures including those (like RV32) that do not define __ARCH_WANT_TIME32_SYSCALLS. * print_timespec.c: Remove. * Makefile.am (libstrace_a_SOURCES): Remove it. * linux/arch_defs_.h (ARCH_TIMESIZE): Remove. (MIN_KLONGSIZE, HAVE_ARCH_TIMESPEC32): New macros. * linux/x32/arch_defs_.h (ARCH_TIMESIZE): Remove. * defs.h (print_timespec32_data_size, print_timespec32_array_data_size): Declare for [HAVE_ARCH_TIMESPEC32]. * kernel_timespec.h (kernel_timespec32_t): Define for [HAVE_ARCH_TIMESPEC32]. * print_timespec32.c (TIMESPEC_T, PRINT_TIMESPEC_DATA_SIZE, PRINT_TIMESPEC_ARRAY_DATA_SIZE): Define for [HAVE_ARCH_TIMESPEC32]. * msghdr.c (PRINT_TIMESPEC_DATA_SIZE, PRINT_TIMESPEC_ARRAY_DATA_SIZE): Define. (print_scm_timestampns_old): Use PRINT_TIMESPEC_DATA_SIZE instead of print_struct_timespec_data_size. (print_scm_timestamping_old): Use PRINT_TIMESPEC_ARRAY_DATA_SIZE instead of print_struct_timespec_array_data_size.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c7130ad35..addbc2239 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -249,7 +249,6 @@ libstrace_a_SOURCES = \
print_statfs.c \
print_struct_stat.c \
print_time.c \
- print_timespec.c \
print_timespec.h \
print_timespec32.c \
print_timespec64.c \