summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEugene Syromyatnikov <evgsyr@gmail.com>2020-04-17 19:48:35 +0200
committerDmitry V. Levin <ldv@altlinux.org>2020-05-30 08:00:00 +0000
commita1f699cfab7349a3706def79c2ce0288325b3d08 (patch)
tree37d289d56c6f1e7159c9ce3dd3bded4e9d691fd8 /Makefile.am
parentd20eb518466ac61423f9df266db650d435985847 (diff)
downloadstrace-a1f699cfab7349a3706def79c2ce0288325b3d08.tar.gz
xlat: generate m4 checks for enumerations
* xlat/gen.sh (print_m4_record, gen_m4_entry): New functions. (print_xlat_pair): Accept macro name in the third argument. (print_xlat, print_xlat_pair): Call print_m4_record. (cond_xlat): Pass $m to print_xlat_pair call. Set first_enum to 0. (gen_header, gen_make, gen_git): Output the "generating ..." line to stderr. (gen_header): Get output_m4 as the fourth parameter, redirect fd 3 to stdout, set enum to 1 if #enum is present and $output_m4 is set, append #include argument to includes, generate $output_m4 is $enum is set to 1, pass macro name to print_xlat_pair call, close fd 3. (gen_git): Add st_check_enums.m4 and "/*.m4". (main): Allow passing $output_m4 as the third argument, pass m4 file name as the fourth argument to gen_header calls, pipe gen_header output to gen_m4_entry in case of no-argument invocation, redirect gen_header output to /dev/null in case of single-file invocation. * Makefile.am (ACLOCAL_AMFLAGS): Add "-I xlat". * configure.ac: Add st_CHECK_ENUMS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ffddc5d02..f5447811b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,7 @@ ARCH = @arch@
READELF = @READELF@
-ACLOCAL_AMFLAGS = -I m4 -I types
+ACLOCAL_AMFLAGS = -I m4 -I types -I xlat
AM_CFLAGS = $(WARN_CFLAGS)
AM_CPPFLAGS = -I$(builddir)/$(OS)/$(ARCH) \
-I$(srcdir)/$(OS)/$(ARCH) \