summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorElvira Khabirova <lineprinter0@gmail.com>2020-09-14 21:18:48 +0300
committerElvira Khabirova <lineprinter0@gmail.com>2020-09-23 15:56:26 +0300
commit8deda3c50b6c51210fc932bd6ddf3cc70256dab3 (patch)
treeae2e04e2a9609cb24ac35c73c3a106f541e7d01c /Makefile.am
parent5f49dd9bc83c004795eb8956a43d9163a21ee28e (diff)
downloadstrace-8deda3c50b6c51210fc932bd6ddf3cc70256dab3.tar.gz
Implement decoding of TEE_* ioctls
* tee.c: New file. * tee.h: Likewise. * Makefile.am (libstrace_a_SOURCES): Add them. * configure.ac (AC_CHECK_HEADERS): Add linux/tee.h. * defs.h (DECL_IOCTL): Add tee. * ioctl.c (ioctl_decode): Add 0xa4 (tee) case. * xlat/tee_ioctl_cmds.in: New file. * xlat/tee_ioctl_gen_caps.in: Likewise. * xlat/tee_ioctl_impl_ids.in: Likewise. * xlat/tee_ioctl_login_types.in: Likewise. * xlat/tee_ioctl_max_arg_size.in: Likewise. * xlat/tee_ioctl_optee_caps.in: Likewise. * xlat/tee_ioctl_origins.in: Likewise. * xlat/tee_ioctl_param_attr_types.in: Likewise. * xlat/tee_ioctl_shm_flags.in: Likewise. * tests/gen_tests.in (ioctl_tee): New entry. * tests/ioctl_tee.c: New file. * tests/.gitignore: Add ioctl_tee. * tests/pure_executables.list: Likewise. * NEWS: Mention the change.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e73e6c3a..8e64a0478 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -345,6 +345,8 @@ libstrace_a_SOURCES = \
sysinfo.c \
syslog.c \
sysmips.c \
+ tee.c \
+ tee.h \
term.c \
time.c \
times.c \