summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2021-01-17 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2021-01-17 08:00:00 +0000
commit863439cb95f3fbed71133f72bf6cb09c2387aace (patch)
tree25ca7fa003c9d3b7a05ca9f846f21b6acd33f96a /Makefile.am
parentb5c0ffd9776cd0cded7b03cecc00830d8d4d062d (diff)
downloadstrace-863439cb95f3fbed71133f72bf6cb09c2387aace.tar.gz
coverage: update genhtml options
* Makefile.am (CODE_COVERAGE_GENHTML_OPTIONS): Add --title, --precision, and --missed options, update --prefix option.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 245c8b4c4..47d0d05dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -416,7 +416,9 @@ endif
@CODE_COVERAGE_RULES@
CODE_COVERAGE_BRANCH_COVERAGE = 1
CODE_COVERAGE_GENHTML_OPTIONS = $(CODE_COVERAGE_GENHTML_OPTIONS_DEFAULT) \
- --prefix $(shell cd $(abs_top_srcdir)/.. && pwd || echo .)
+ --title "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ --precision 2 --missed \
+ --prefix $(abspath $(abs_top_srcdir)/..)
CODE_COVERAGE_IGNORE_PATTERN = '/usr/include/*' '*/tests/*' '*/tests-m32/*' '*/tests-mx32/*'
strace_CPPFLAGS += $(CODE_COVERAGE_CPPFLAGS)
strace_CFLAGS += $(CODE_COVERAGE_CFLAGS)