summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-03-27 22:28:02 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-03-27 22:28:02 +0000
commit7a892cf761d31e726d58dc06c9c643ef9aba3d64 (patch)
tree2f0ed2ec999467fb618ba1a81c2d78d2f1ed03b8 /Makefile.am
parent5e5b0b3e7c47c2fb2ea0dd1f1d3e6ec9137334f3 (diff)
downloadstrace-7a892cf761d31e726d58dc06c9c643ef9aba3d64.tar.gz
hppa: switch to PTRACE_GETREGS API
Implement PTRACE_GETREGS API introduced on hppa by Linux kernel commit v4.7-rc1~58^2~10. * configure.ac [hppa]: Remove arch_enable_Werror=no. * linux/hppa/get_syscall_result.c: Remove. * Makefile.am (EXTRA_DIST): Remove it. * linux/hppa/arch_regs.c (hppa_regs): New variable. (ARCH_REGS_FOR_GETREGS, ARCH_PC_REG, ARCH_SP_REG): New macros. (hppa_r28, PT_GR20, PT_GR28, ARCH_PC_PEEK_ADDR, ARCH_SP_PEEK_ADDR): Remove. * linux/hppa/get_error.c (arch_get_error): Use hppa_regs.gr[28]. * linux/hppa/get_scno.c (arch_get_scno): Use hppa_regs.gr[20]. * linux/hppa/get_syscall_args.c (arch_get_syscall_args): Use hppa_regs.gr. * linux/hppa/set_error.c (arch_set_error, arch_set_success): Use hppa_regs.gr[28]. * linux/hppa/set_scno.c (arch_set_scno): Use hppa_regs.gr[20]. * NEWS: Mention this change.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fe3a2c1a1..0f6bfa189 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -558,7 +558,6 @@ EXTRA_DIST = \
linux/hppa/get_error.c \
linux/hppa/get_scno.c \
linux/hppa/get_syscall_args.c \
- linux/hppa/get_syscall_result.c \
linux/hppa/ioctls_arch0.h \
linux/hppa/ioctls_inc0.h \
linux/hppa/raw_syscall.h \