summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2019-09-23 23:19:45 +0000
committerDmitry V. Levin <ldv@altlinux.org>2019-09-23 23:19:45 +0000
commit69ff62ea5087506ad36a27599db088096db215da (patch)
tree272b1dd6df88e0e7841163dd366ca02f4a39b6d8 /Makefile.am
parent91fbffc06dd364b528eb564807c99c73a43a88f9 (diff)
downloadstrace-69ff62ea5087506ad36a27599db088096db215da.tar.gz
riscv: rename to riscv64
The only currently supported RISC-V architecture is the 64-bit RISC-V. As the generic name we use causes confusion [1], rename it to riscv64. [1] https://lists.strace.io/pipermail/strace-devel/2019-August/009057.html * Makefile.am (EXTRA_DIST): Rename linux/riscv to linux/riscv64. * configure.ac: Rename riscv to riscv64, RISCV to RISCV64. * linux/riscv: Rename to linux/riscv64. * riscv.c: Rename RISCV to RISCV64. * tests/options-syntax.test: Rename riscv to riscv64. * tests/qualify_personality.sh: Likewise. * tests/strace-V.test: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index b4f31568f..f4a93e9e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -739,21 +739,21 @@ EXTRA_DIST = \
linux/powerpc64le/userent.h \
linux/ptrace_pokeuser.c \
linux/raw_syscall.h \
- linux/riscv/arch_defs_.h \
- linux/riscv/arch_get_personality.c \
- linux/riscv/arch_regs.c \
- linux/riscv/get_error.c \
- linux/riscv/get_scno.c \
- linux/riscv/get_syscall_args.c \
- linux/riscv/ioctls_arch0.h \
- linux/riscv/ioctls_arch1.h \
- linux/riscv/ioctls_inc0.h \
- linux/riscv/ioctls_inc1.h \
- linux/riscv/raw_syscall.h \
- linux/riscv/set_error.c \
- linux/riscv/set_scno.c \
- linux/riscv/syscallent.h \
- linux/riscv/syscallent1.h \
+ linux/riscv64/arch_defs_.h \
+ linux/riscv64/arch_get_personality.c \
+ linux/riscv64/arch_regs.c \
+ linux/riscv64/get_error.c \
+ linux/riscv64/get_scno.c \
+ linux/riscv64/get_syscall_args.c \
+ linux/riscv64/ioctls_arch0.h \
+ linux/riscv64/ioctls_arch1.h \
+ linux/riscv64/ioctls_inc0.h \
+ linux/riscv64/ioctls_inc1.h \
+ linux/riscv64/raw_syscall.h \
+ linux/riscv64/set_error.c \
+ linux/riscv64/set_scno.c \
+ linux/riscv64/syscallent.h \
+ linux/riscv64/syscallent1.h \
linux/rt_sigframe.h \
linux/s390/arch_defs_.h \
linux/s390/arch_regs.c \