summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-03-29 22:50:54 +0000
committerEugene Syromyatnikov <evgsyr@gmail.com>2020-03-30 23:14:24 +0200
commit68aef4378160b6bda355803a7df9bd60972e65d3 (patch)
treed59a58592de8e83f7043538b302ab3b1bfeeaeb4 /Makefile.am
parent9e24fed54d1867cbbd4f3d652676d90dc70c8292 (diff)
downloadstrace-68aef4378160b6bda355803a7df9bd60972e65d3.tar.gz
sh: switch to PTRACE_GETREGS API
Implement PTRACE_GETREGS API introduced on sh by Linux kernel commit v2.6.28-rc1~99^2~56. * configure.ac [sh]: Remove arch_enable_Werror=no. * linux/sh/get_syscall_result.c: Remove. * Makefile.am (EXTRA_DIST): Remove it. * linux/sh/arch_regs.c (sh_regs): New variable. (ARCH_REGS_FOR_GETREGS, ARCH_PC_REG, ARCH_SP_REG): New macros. (sh_r0, ARCH_PC_PEEK_ADDR, ARCH_SP_PEEK_ADDR): Remove. * linux/sh/arch_getrval2.c (getrval2): Use sh_regs.regs[1]. * linux/sh/get_error.c (arch_get_error): Use sh_regs.regs[0]. * linux/sh/get_scno.c (arch_get_scno): Use sh_regs.regs[3]. * linux/sh/get_syscall_args.c (arch_get_syscall_args): Use sh_regs.regs. * linux/sh/set_error.c (arch_set_error, arch_set_success): Use sh_regs.gr[0]. * linux/sh/set_scno.c (arch_set_scno): Use sh_regs.regs[3]. * NEWS: Mention this change.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0f6bfa189..4fd612465 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -799,7 +799,6 @@ EXTRA_DIST = \
linux/sh/get_error.c \
linux/sh/get_scno.c \
linux/sh/get_syscall_args.c \
- linux/sh/get_syscall_result.c \
linux/sh/ioctls_arch0.h \
linux/sh/ioctls_inc0.h \
linux/sh/raw_syscall.h \