summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2021-02-04 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2021-02-04 08:00:00 +0000
commit5bd8364f4202d46186de14cf7f708d33e3196b60 (patch)
tree15491d67cb2569551367b47f9a2f910d98d204d3 /Makefile.am
parent8db560f7ee1f521ed416b7dae45f7386b0f4fbf7 (diff)
downloadstrace-5bd8364f4202d46186de14cf7f708d33e3196b60.tar.gz
Introduce bundled directory
This is the first step of adding bundled Linux kernel UAPI headers for compatibility purposes. These headers are going to be copied verbatim from the Linux kernel, they are provided by the Linux kernel under the terms of the GNU General Public License version 2 only with an explicit syscall exception. According to analysis made by Kent Gibson at [1], we are allowed to re-distribute unmodified Linux kernel UAPI headers under the same terms as they are provided by the Linux kernel, and such re-distribution does not affect the license of strace itself. [1] https://lore.kernel.org/linux-gpio/20210128032641.GA11655@sol/ * bundled/Makefile.am: New file. * configure.ac (AC_CONFIG_FILES): Add bundled/Makefile. * Makefile.am (SUBDIRS): Add bundled. * bundled/linux/GPL-2.0: New file, copied from Linux kernel v5.10:LICENSES/preferred/GPL-2.0 file. * bundled/linux/Linux-syscall-note: New file, copied from Linux kernel v5.10:LICENSES/exceptions/Linux-syscall-note file. * bundled/linux/COPYING: New file. * COPYING: Mention it. Thanks-to: Kent Gibson <warthog618@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a44879b0c..02ca8e0eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,7 @@ endif
if HAVE_MX32_RUNTIME
TESTS_MX32 = tests-mx32
endif
-SUBDIRS = src tests $(TESTS_M32) $(TESTS_MX32)
+SUBDIRS = bundled src tests $(TESTS_M32) $(TESTS_MX32)
man_MANS = doc/strace.1 doc/strace-log-merge.1