summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <vda.linux@googlemail.com>2012-02-25 02:30:32 +0100
committerDenys Vlasenko <vda.linux@googlemail.com>2012-02-25 02:30:32 +0100
commit5afdf12572bee4ddf5a7b136d94fde024a01f642 (patch)
treecde2d6a8c1b45f20e1fcdd4ba13d6c8431977df8 /Makefile.am
parented720fda5d515f1359fcd3242223e553d1216789 (diff)
downloadstrace-5afdf12572bee4ddf5a7b136d94fde024a01f642.tar.gz
Manual removal of non-Linux source, documentation, etc.
Remove non-Linux source directories: freebsd/, svr4/, sunos4/, svr4/. Remove README-freebsd, README-sunos4, README-svr4, m4/procfs.m4. linux/sparc/{errnoent1,ioctlent1,signalent1}.h used to point to svr4/ files - replace their contents with copies of used (and now deleted) files. Make linux/sparc64/{errnoent1,ioctlent1,signalent1}.h include these files instead of svr4/* ones. Makefile.am: remove references to deleted files. configure.ac: Remove a few tests which make no sense on Linux. Man page: remove non-Linux quirks information. Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 123102227..35058d78a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ bin_PROGRAMS = strace
man_MANS = strace.1
bin_SCRIPTS = strace-graph
-# OS is one of `linux', `sunos4', `svr4', or `freebsd'.
+# OS is `linux'
OS = @opsys@
# ARCH is `i386', `m68k', `sparc', etc.
ARCH = @arch@
@@ -29,7 +29,7 @@ EXTRA_DIST = $(man_MANS) errnoent.sh signalent.sh syscallent.sh ioctlsort.c \
debian/strace.manpages debian/strace-udeb.install \
strace.spec \
strace-graph ChangeLog ChangeLog-CVS COPYRIGHT CREDITS PORTING \
- README-freebsd README-linux README-sunos4 README-svr4 \
+ README-linux \
linux/ioctlsort.c linux/ioctlent.sh \
linux/ioctlent.h.in linux/errnoent.h linux/signalent.h \
linux/syscall.h linux/dummy.h \
@@ -82,16 +82,6 @@ EXTRA_DIST = $(man_MANS) errnoent.sh signalent.sh syscallent.sh ioctlsort.c \
linux/x86_64/gentab.pl \
linux/x86_64/errnoent1.h linux/x86_64/ioctlent1.h \
linux/x86_64/signalent1.h linux/x86_64/syscallent1.h \
- freebsd/ioctlent.sh \
- freebsd/syscalls.cat freebsd/syscalls.pl freebsd/syscalls.print \
- freebsd/i386/errnoent.h freebsd/i386/ioctlent.h \
- freebsd/i386/signalent.h \
- freebsd/i386/syscall.h freebsd/i386/syscallent.h \
- sunos4/dummy.h sunos4/errnoent.h \
- sunos4/ioctlent.h sunos4/ioctlent.sh sunos4/signalent.h \
- sunos4/syscall.h sunos4/syscallent.h \
- svr4/dummy.h svr4/errnoent.h svr4/ioctlent.h svr4/ioctlent.sh \
- svr4/signalent.h svr4/syscall.h svr4/syscallent.h \
xlate.el
.PHONY: srpm