summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2021-02-02 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2021-02-02 08:00:00 +0000
commit5685c0d0335246b37c57e65303c82206bdd45e65 (patch)
treedcd6cceab3940c59222b79085c6242ef33253313 /Makefile.am
parent1f879c6fa1cf5ec5be5030c3400db17f1b3adc36 (diff)
downloadstrace-5685c0d0335246b37c57e65303c82206bdd45e65.tar.gz
Do not install strace-graph
Apparently, nobody uses this utility, since it barely works, and nobody complained. For example, $ strace -qe/exit -o'|./strace-graph' true Use of uninitialized value $pid in concatenation (.) or string at ./strace-graph line 207, <> line 1. Use of uninitialized value $time in concatenation (.) or string at ./strace-graph line 207, <> line 1. Use of uninitialized value $pid in hash element at ./strace-graph line 214, <> line 1. Use of uninitialized value $pid in delete at ./strace-graph line 244, <> line 1. Use of uninitialized value $startpid in hash element at ./strace-graph line 336, <> line 2. Use of uninitialized value $pid in hash element at ./strace-graph line 284, <> line 2. Can't use an undefined value as an ARRAY reference at ./strace-graph line 284, <> line 2. This is not surprising because downstreams stopped packaging strace-graph long time ago. * Makefile.am (bin_SCRIPTS): Remove strace-graph. * strace.spec.in (%install): Stop removing strace-graph.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b72c91222..2e123006a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@ SUBDIRS = . tests $(TESTS_M32) $(TESTS_MX32)
bin_PROGRAMS = strace
man_MANS = strace.1 strace-log-merge.1
-bin_SCRIPTS = strace-graph strace-log-merge
+bin_SCRIPTS = strace-log-merge
OS = linux
# ARCH is `i386', `m68k', `sparc', etc.