summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKent Gibson <warthog618@gmail.com>2021-01-23 09:56:41 +0800
committerDmitry V. Levin <ldv@strace.io>2021-01-26 08:00:00 +0000
commit50e72291f8ef4ce1ddc8b17cd71254c0d1dc1ea1 (patch)
tree9f7f18154161972bd3e175110ec168024464c75e /Makefile.am
parent9b46536a8f71d38eac9723d7021e8fb0b82e6a97 (diff)
downloadstrace-50e72291f8ef4ce1ddc8b17cd71254c0d1dc1ea1.tar.gz
Add GPIO ioctl decoding
Decode the GPIO character device ioctls first introduced in Linux v4.6, as well as those added in subsequent kernel releases up to Linux v5.7. Signed-off-by: Kent Gibson <warthog618@gmail.com> * gpio_ioctl.c: New file. * Makefile.am (libstrace_a_SOURCES): Add it. * types/gpio.h: New file. * xlat/gpio_event_flags.in: Likewise. * xlat/gpio_handle_flags.in: Likewise. * xlat/gpio_ioctl_cmds.in: Likewise. * xlat/gpio_line_flags.in: Likewise. * defs.h (DECL_IOCTL): Add gpio. * ioctl.c (ioctl_decode): Add 0xb4 case. * NEWS: Mention this change. Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 47d0d05dd..ecdd5c326 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -143,6 +143,7 @@ libstrace_a_SOURCES = \
getpagesize.c \
getpid.c \
getrandom.c \
+ gpio_ioctl.c \
hdio.c \
hostname.c \
inotify.c \