summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2021-01-27 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2021-01-27 08:00:00 +0000
commit43562b1bf98ab71919e0184acce14313bbdeccff (patch)
treef551d46944478add92106d65541b2c73d63cc594 /Makefile.am
parentde8fce0b9996039a5d3b19ba9a0a6842fe7b6a2c (diff)
downloadstrace-43562b1bf98ab71919e0184acce14313bbdeccff.tar.gz
print_fields.h: introduce a few tprint_* helper inline functions
These functions are going to be needed for removal of the first argument from PRINT_FIELD_* macros. * Makefile.am (strace_CPPFLAGS): Add -DIN_STRACE=1. * print_fields.h (tprint_{struct,array}_{begin,next,end}, tprint_more_data_follows, tprint_value_changed, tprints_field_name): New inline functions. (STRACE_PRINTF): New macro. * tests/tests.h (STRACE_PRINTF): Remove.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ecdd5c326..e10da497c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,7 @@ AM_CPPFLAGS_FOR_BUILD = $(AM_CPPFLAGS)
include types/Makemodule.am
include xlat/Makemodule.am
-strace_CPPFLAGS = $(AM_CPPFLAGS)
+strace_CPPFLAGS = $(AM_CPPFLAGS) -DIN_STRACE=1
strace_CFLAGS = $(AM_CFLAGS)
strace_LDFLAGS =
strace_LDADD = libstrace.a $(clock_LIBS) $(timer_LIBS)