summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2021-02-02 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2021-02-02 08:00:00 +0000
commit1c38fe83a470be9fd9682af459b361204a063d4d (patch)
treea6f37a87aa2403063e73d2a6ffd46d24116711a5 /Makefile.am
parent60c2d48b760ab9cc1d8600d1009de0c3eaf74e48 (diff)
downloadstrace-1c38fe83a470be9fd9682af459b361204a063d4d.tar.gz
Move auxiliary build scripts to build-aux subdirectory
* copyright-year-gen: Rename to build-aux/copyright-year-gen. * file-date-gen: Rename to build-aux/file-date-gen. * git-set-file-times: Rename to build-aux/git-set-file-times. * git-version-gen: Rename to build-aux/git-version-gen. * gitlog-to-changelog: Rename to build-aux/gitlog-to-changelog. * Makefile.am (EXTRA_DIST): Rename copyright-year-gen to build-aux/copyright-year-gen, file-date-gen to build-aux/file-date-gen, and git-version-gen to build-aux/git-version-gen. ($(srcdir)/ChangeLog): Rename gitlog-to-changelog to build-aux/gitlog-to-changelog. * ci/run-build-and-tests.sh: Rename git-set-file-times to build-aux/git-set-file-times. * configure.ac: Rename git-version-gen to build-aux/git-version-gen, copyright-year-gen to build-aux/copyright-year-gen, and file-date-gen to build-aux/file-date-gen. * maint/make-dist: Rename git-set-file-times to build-aux/git-set-file-times. * maint/update_copyright_years.sh: Rename git-set-file-times to build-aux/git-set-file-times, gitlog-to-changelog to build-aux/gitlog-to-changelog.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e123006a..b9744acff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -438,7 +438,9 @@ EXTRA_DIST = \
LGPL-2.1-or-later \
README-configure \
README-linux-ptrace \
- copyright-year-gen \
+ build-aux/copyright-year-gen \
+ build-aux/file-date-gen \
+ build-aux/git-version-gen \
debian/changelog \
debian/compat \
debian/control \
@@ -454,10 +456,8 @@ EXTRA_DIST = \
debian/strace64.manpages \
debian/watch \
disable_ptrace_request.c \
- file-date-gen \
gen_bpf_attr_check.sh \
generate_sen.sh \
- git-version-gen \
ioctl_iocdef.c \
ioctlsort.c \
linux/32/ioctls_inc.h \
@@ -1222,11 +1222,11 @@ clean-local:
if MAINTAINER_MODE
gen_changelog_start_date = 2009-07-08 20:00
-$(srcdir)/ChangeLog: $(srcdir)/gitlog-to-changelog $(srcdir)/Makefile.in \
+$(srcdir)/ChangeLog: $(srcdir)/build-aux/gitlog-to-changelog $(srcdir)/Makefile.in \
$(srcdir)/.version
@rm -f $@.new
(cd $(srcdir); \
- ./gitlog-to-changelog --append-dot \
+ ./build-aux/gitlog-to-changelog --append-dot \
--since='$(gen_changelog_start_date)'; \
echo; echo; echo 'See ChangeLog-CVS for older changes.' \
) > $@.new