summaryrefslogtreecommitdiff
path: root/sloccount.spec
diff options
context:
space:
mode:
authordwheeler <dwheeler@d762cc98-fd17-0410-9a0d-d09172385bc5>2006-07-07 13:36:27 +0000
committerdwheeler <dwheeler@d762cc98-fd17-0410-9a0d-d09172385bc5>2006-07-07 13:36:27 +0000
commit05095851346f52c8e918176e8e2abdf0b21de5ec (patch)
tree8de964f5eea4c7d80faf34d5d744e215a053ba8f /sloccount.spec
downloadsloccount-05095851346f52c8e918176e8e2abdf0b21de5ec.tar.gz
Initial import (sloccount 2.26)HEADmaster
git-svn-id: svn://svn.code.sf.net/p/sloccount/code/trunk@1 d762cc98-fd17-0410-9a0d-d09172385bc5
Diffstat (limited to 'sloccount.spec')
-rw-r--r--sloccount.spec56
1 files changed, 56 insertions, 0 deletions
diff --git a/sloccount.spec b/sloccount.spec
new file mode 100644
index 0000000..62dd7b4
--- /dev/null
+++ b/sloccount.spec
@@ -0,0 +1,56 @@
+#
+# RPM spec file for "sloccount".
+#
+%define PKG_VERSION 2.26
+
+Name: sloccount
+Summary: Measures source lines of code (SLOC) in programs
+Version: %{PKG_VERSION}
+Release: 1
+Copyright: GPL
+Group: Development/Tools
+Source: http://www.dwheeler.com/sloccount/sloccount-%{PKG_VERSION}.tar.gz
+URL: http://www.dwheeler.com/sloccount
+Vendor: David A. Wheeler
+Packager: David A. Wheeler <dwheeler@dwheeler.com>
+Prefix: /usr
+BuildRoot: /var/tmp/%name-buildroot
+
+%description
+SLOCCount (pronounced "sloc-count") is a suite of programs for counting
+physical source lines of code (SLOC) in potentially large software systems
+(thus, SLOCCount is a "software metrics tool" or "software measurement tool").
+SLOCCount can count physical SLOC for a wide number of languages;
+listed alphabetically, they are: Ada, Assembly, awk, Bourne shell, C, C++,
+C shell, COBOL, Expect, Fortran, Java, lex/flex, LISP (including Scheme),
+Modula-3, Objective-C, Pascal, Perl, PHP, Python, sed, TCL, and Yacc.
+SLOCCount can automatically determine if a file
+is a source code file or not, and if so, which language it's written in.
+As a result, you can analyze large systems completely automatically;
+it's been used to examine entire GNU/Linux distributions, for example.
+SLOCCount also includes some report-generating tools
+to collect the data generated and present it in several different formats.
+Normally you can just run "sloccount DIRECTORY" and all the source code
+in the directory and its descendants will be counted.
+
+%prep
+%setup
+
+%build
+make
+
+%install
+rm -rf ${RPM_BUILD_ROOT}
+mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
+mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
+make install_programs PREFIX=${RPM_BUILD_ROOT}%{_prefix}
+make install_man PREFIX=${RPM_BUILD_ROOT}%{_prefix}
+
+%clean
+rm -rf ${RPM_BUILD_ROOT}
+
+%files
+%defattr(-, root, root)
+%doc sloccount.html README ChangeLog COPYING TODO
+%{_bindir}/*
+%{_mandir}/*/*