summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2023-02-04 13:44:19 -0800
committerBob Ippolito <bob@redivi.com>2023-02-04 15:37:45 -0800
commitfb7f4004788aa939af4e766262a02b9bad0f70a9 (patch)
tree423c9bde714beb0dcc8649a3336031e1c19183c7 /setup.py
parentc891b95f40711e3dcd23bd4180b5665dce3a2032 (diff)
downloadsimplejson-fb7f4004788aa939af4e766262a02b9bad0f70a9.tar.gz
Fix #307. Build a pure python wheel
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e5bebd5..9bd1dd3 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ from distutils.errors import CCompilerError, DistutilsExecError, \
DistutilsPlatformError
IS_PYPY = hasattr(sys, 'pypy_translation_info')
-VERSION = '3.18.1'
+VERSION = '3.18.2'
DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
with open('README.rst', 'r') as f:
@@ -118,7 +118,7 @@ def run_setup(with_binary):
**kw)
try:
- run_setup(not IS_PYPY)
+ run_setup(not IS_PYPY and os.environ.get('DISABLE_SPEEDUPS') != '1')
except BuildFailed:
if os.environ.get('REQUIRE_SPEEDUPS') or os.environ.get('CIBUILDWHEEL', '0') == '1':
raise