summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2021-07-06 14:01:46 -0700
committerBob Ippolito <bob@redivi.com>2021-07-09 16:07:50 -0700
commit949aeefd17eea3f597bf549af43d007381cc077d (patch)
tree1c7928fddf0202628968605164542a055bd599a0 /setup.py
parent8bef979ad8272cbc2903970f4b9992f603d50973 (diff)
downloadsimplejson-949aeefd17eea3f597bf549af43d007381cc077d.tar.gz
Replace travis and appveyor with github actions
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3252f2f..bfe8f25 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ from distutils.errors import CCompilerError, DistutilsExecError, \
DistutilsPlatformError
IS_PYPY = hasattr(sys, 'pypy_translation_info')
-VERSION = '3.17.2'
+VERSION = '3.17.3'
DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
with open('README.rst', 'r') as f:
@@ -36,6 +36,8 @@ CLASSIFIERS = [
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries :: Python Modules',
@@ -116,7 +118,7 @@ def run_setup(with_binary):
try:
run_setup(not IS_PYPY)
except BuildFailed:
- if os.environ.get('REQUIRE_SPEEDUPS'):
+ if os.environ.get('REQUIRE_SPEEDUPS') or os.environ.get('CIBUILDWHEEL', '0') == '1':
raise
BUILD_EXT_WARNING = ("WARNING: The C extension could not be compiled, "
"speedups are not enabled.")