summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTal Einat <taleinat@gmail.com>2017-06-28 10:37:52 +0300
committerGitHub <noreply@github.com>2017-06-28 10:37:52 +0300
commit687d0e80f377c252451a4067acbcdc2e1db88a00 (patch)
treea8f421b38912885bdcd253acad22d3950de58407 /setup.py
parentcae6d7b381bc07ed6aad97a52a41713ee29c6a37 (diff)
downloadsimplejson-687d0e80f377c252451a4067acbcdc2e1db88a00.tar.gz
setup.py: fix condition for build_ext exception types
The comment states that IOError and ValueError can be thrown in Python 2.6. The referenced CPython issue supports this, it seems to have been resolved in version 2.7. However, the code seems to have the condition backwards, and will only catch IOError or ValueError in versions *greater* than 2.6.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fd304f1..aaad55b 100644
--- a/setup.py
+++ b/setup.py
@@ -38,7 +38,7 @@ Programming Language :: Python :: Implementation :: PyPy
Topic :: Software Development :: Libraries :: Python Modules
""".splitlines()))
-if sys.platform == 'win32' and sys.version_info > (2, 6):
+if sys.platform == 'win32' and sys.version_info < (2, 7):
# 2.6's distutils.msvc9compiler can raise an IOError when failing to
# find the compiler
# It can also raise ValueError http://bugs.python.org/issue7511