summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2017-11-24 09:13:46 -0800
committerBob Ippolito <bob@redivi.com>2017-11-24 09:15:02 -0800
commit518401fc950fb76848f9a170e3cfb35b5dfcfbff (patch)
tree1a370b94d2d7b31f2be463c8da253c85cadc77d4 /setup.py
parent708026ea6ee10ffa15b9a28d5b06bb9b45a9da24 (diff)
downloadsimplejson-518401fc950fb76848f9a170e3cfb35b5dfcfbff.tar.gz
fail build in CI if speedups do not build correctly
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index feb29d9..dc3e378 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
#!/usr/bin/env python
from __future__ import with_statement
+import os
import sys
try:
from setuptools import setup, Extension, Command
@@ -112,6 +113,8 @@ def run_setup(with_binary):
try:
run_setup(not IS_PYPY)
except BuildFailed:
+ if os.environ.get('REQUIRE_SPEEDUPS'):
+ raise
BUILD_EXT_WARNING = ("WARNING: The C extension could not be compiled, "
"speedups are not enabled.")
print('*' * 75)