summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSerhiy Storchaka <storchaka@gmail.com>2017-12-03 00:14:57 +0200
committerSerhiy Storchaka <storchaka@gmail.com>2017-12-03 00:14:57 +0200
commit3b26a2e989ebb6c5658d73eebf65fa3648d27832 (patch)
tree0b86d47aee6eaa54b89a1b037bc6a4c87f9ab1ce /setup.py
parent3cf08530a1be05cbaa80b167fe7f335b13cbc869 (diff)
downloadsimplejson-3b26a2e989ebb6c5658d73eebf65fa3648d27832.tar.gz
The classifier parameter in setup.py must be a list.setup-classifiers
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 19 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 754acfc..7d2d6c5 100644
--- a/setup.py
+++ b/setup.py
@@ -18,26 +18,25 @@ DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
with open('README.rst', 'r') as f:
LONG_DESCRIPTION = f.read()
-CLASSIFIERS = filter(None, map(str.strip,
-"""
-Development Status :: 5 - Production/Stable
-Intended Audience :: Developers
-License :: OSI Approved :: MIT License
-License :: OSI Approved :: Academic Free License (AFL)
-Programming Language :: Python
-Programming Language :: Python :: 2
-Programming Language :: Python :: 2.5
-Programming Language :: Python :: 2.6
-Programming Language :: Python :: 2.7
-Programming Language :: Python :: 3
-Programming Language :: Python :: 3.3
-Programming Language :: Python :: 3.4
-Programming Language :: Python :: 3.5
-Programming Language :: Python :: 3.6
-Programming Language :: Python :: Implementation :: CPython
-Programming Language :: Python :: Implementation :: PyPy
-Topic :: Software Development :: Libraries :: Python Modules
-""".splitlines()))
+CLASSIFIERS = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'License :: OSI Approved :: Academic Free License (AFL)',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+]
if sys.platform == 'win32' and sys.version_info < (2, 7):
# 2.6's distutils.msvc9compiler can raise an IOError when failing to